Honeywell evohome Battery Life/Charging Issues...

Before you use our forum please read this section!

Honeywell evohome Battery Life/Charging Issues...

Postby The EVOHOME Shop » Wed Dec 06, 2017 3:02 pm

Hi All,

We get about 3 calls a week about the evohome Controller and its batteries! So please read the following information! 8-)

The Honeywell evohome Controller is supposed to be a 'docked product' and was not designed to be taken around the house with you! :geek: The ability for it to be removed from the dock or wall plate is so you can program and adjust settings more easily... ;)

However, when you remove the evohome Controller from the dock and the batteries go flat almost immediately, three main issues have possibly occurred here...

1. The batteries needed fully charging properly when the device was first taken out the box, but were not.
2. The evohome Controller does not know what voltage the batteries are.
3. The charge plug needs pushing into the ATF800 properly (newer date coded units come with the cable already fitted to the ATF800).

Please follow my instructions below (I wrote these several months ago on another forum):

"Put the evohome Controller on the ATF800 charge stand, make sure the charge stand is powered (not switched off) and then remove the evohome fascia. Part the batteries in the middle (so they don't touch each other) while it is docked on the charge stand (the plastic leg on the lid of a BIC pen is great for this). Within a few seconds, the battery symbol will go to a battery symbol with a X (cross) through it. At this point un-part the batteries and you will notice the battery symbol change to a battery symbol with a lightning bolt through it. Leave the device charge until the battery symbol disappears (may take 4-16 hours to do this). Then remove the evohome Controller from the stand and allow the batteries to discharge (can take up to 6 hours) and then when you get the screen where it will do nothing and says 'put me back on the stand'... Do this and charge the fully batteries again.

You will find if you repeat this once every couple of months the batteries will last just fine (4-6 hours easy).

You may also find the plug you push in the back of the ATF800 is not pushed in fully! When you push the plug into the charge stand it will go in with a 'click'! Make sure this happens or it won't power the ATF800 correctly which will mean the batteries will not charge!"


I hope that helps.

Thanks,

Richard
The EVOHOME Shop customer? :D Need further help or support? :oops: Contact us on technical@theevohomeshop.co.uk (please quote your order reference) 8-)
The EVOHOME Shop
Site Admin
 
Posts: 635
Joined: Fri Jun 10, 2016 4:08 pm

Return to Welcome to The EVOHOME Forum

Who is online

Users browsing this forum: No registered users and 1 guest

cron